1
0
-1

I have added a 'TM Attachment Table' and I am editing the properties for 'Attachments', 'Data Binding'. I have selected 'Absolute' and click on the Browse button. It states 'You can use this dialog to select a binding reference', but it is empty!
I click close and can add the binding reference manually '$record.SFMData.Attachments.ItemList.Item'. I publish the form (HTML and PDF) and open them (I have Attachments included inTransact).It works in HTML but not in PDF.
Thanks Tim

Attachments added to support comments below:

TMAttachmentSettings.docx

TM Attachment Table.docx

  1. Howard Treisman
    Hi Tim
    The TM Attachment table is pre-bound to the right place that TM expect, you don't need to bind it explicitly. In fact, trying to explicitly bind it will break it.
    Can I ask what exactly you're trying to achieve?
    Thanks,
    Howard
  2. Unknown User (tim.nash@industry.gov.au)
    Howard,
    I have added some Attachments in Transact, and I have added a TM Attachment Table so that the user can see what attachments are required prior to submitting document. After publishing Composer form, I test the form in PDF and HTMLand it is not working as I believe it should (i.e. displaying a list of attachments required).
    I can give you the composer path if that helps
    Thanks Tim
  3. Chantal Thomas
    Hi Tim,
    I have passed the issue to our support people and will let you know what the outcome is.
    Thanks
    Chantal
  4. Unknown User (kelliott)
    Hi Tim,
    Also Attachments are meant as a process in the portal after form submission and should be relatively bound. You should see the list in PDF and in HTML. Changing the binding to Absolute will break it.
    Thanks,
    Kristan
  5. Unknown User (tim.nash@industry.gov.au)
    Hi Kristan,
    I have tested this, by copying a working version of 'TM Attachment Table' that Thambadid. And as suggested, I also dragged one in and left the default setting (i.e.relative bound). The relative bound TM Attachment Table does not display any results. The one from Thamba showed results in the html (although incorrectly)and not in the pdf. (see attached file)
    Thanks Tim
  6. Unknown User (kelliott)
    Hi Tim,
    It looks like from your screen shot the table that was copied over has broken somehow and that is why it appears at it does. Can you confirm that you have at least one "TM attachment rule" in your table and also what you have the initial row count set to?

    Thanks!
  7. Unknown User (tim.nash@industry.gov.au)
    Hi Kristan,
    I have tried a variety of settings. Attached are the current settings.
    Thanks
    Tim
  8. Unknown User (kelliott)
    Hi Tim,
    Can you expand the table and see if there is an "TM Attachment Rule" in side the table?
    Thanks!
  9. Unknown User (kelliott)
    Here is a link to the documentation for the Composer User Manual, it is a PDF. Refer to Section 3.7 Adding Attachments.
    If you are still having issues it may be best to open a ticket to resolve this.
    Thanks!
    Kristan
  10. Unknown User (tim.nash@industry.gov.au)
    Kristan,
    No link in your latest message?
    Also, the settings you asked about were the default settings.
    Thanks Tim
CommentAdd your comment...

1 answer

  1.  
    1
    0
    -1
    1. Unknown User (kelliott)
      I apologize I left this out.
      https://avoka.zendesk.com/entries/32094347-3-6-Composer-User-Manual
      Thanks!
      Kristan
    CommentAdd your comment...