1
0
-1

We are currently having an issue when trying to upload a remote archive from an IDE using the "POST Upload Service Archive". The zip archive builds just fine, but we get an issue accessing the TM instance itself.

  [gupload] Request: POST <host>/manager/secure/rest/service-definitions/v1/upload-service-archive/ HTTP/1.1
  [gupload] java.net.UnknownHostException: <host>
("<host>" replaces the server url for privacy reasons).

We get an "UnknownHostException". My question being, is this more related to a server setup issue (whitelisting etc.) or is there a config that needs to happen in TM itself?

I am wondering if the credentials used need to be part of a special group/role?

Any guidance would be appreciated.

Thanks!

 

 

    CommentAdd your comment...

    3 answers

    1.  
      2
      1
      0

      Hi Lance,

      I believe the error you have there is more to a connectivity issue (your IDE simply cannot resolve the target address), so yes, whitelisting may be a factor in this.

      For a permission or configuration related error, you'd expect to see either a 404 (Not Found) or a 401 (Unauthorized) response.

      By the way, there are a few settings you will need to configure in Transaction Manager as well. To quote the guidelines under the Groovy Service Invoke topic in the Transaction Manager Transact Services Guide:

      "To enable Groovy Services to be invoked via REST API the service parameter 'REST Invoke Enabled' service parameter must be enabled. By default the service parameter is false, and it must be explicitly enabled.

      To access the Groovy Service Invoke REST endpoint the caller needs to be authenticated using HTTP Basic Authentication. The authenticated user will need an user account on the TM server and this account will need to be active and have access to the Management Console module.

      To be authorized to call the service the user account will also need the Management Console permission 'REST Groovy Service Invoke'.

      If the user is not a global administrator, only services belonging to the organizations assigned to the user will be accessible."

      Hope this helps.

        CommentAdd your comment...
      1.  
        1
        0
        -1

        You might have to configure the proxy settings in Eclipse. Also don't forget to configure your build scripts to run in the same JRE as the workspace, otherwise the JRE won't pick up the proxy settings from Eclipse.

        If your organisation uses an NTLM proxy then you'll have to do a bit more work; check out http://ntlmaps.sourceforge.net/.

          CommentAdd your comment...
        1.  
          1
          0
          -1

          Hi Matthew, 

          Thank you for your response. I had the client open their console and run a nslookup command on the host, and it was unable to resolve there. That points me toward the side of a server config issue. They say the ports are open between them and Avoka and they can access the domain directly in a browser just fine.

           

          I do not come from a server configuration background, but research pointed me toward creating a "Reverse DNS Zone" on the machine/server? they are also asking about a place to configure the proxy in Eclipse. Any ideas on something like this?

           

          Thanks!

            CommentAdd your comment...