1
0
-1

I'm trying to populate a Data Field with the contents of a resource file. I see the "Uploaded Data Resource" option in Composer that seems like it would do what I'm trying to do, but I can't get it to work after deploying to TM (It works when previewing). Has anyone ever gotten this feature to work or know how it's supposed to work?

 

    CommentAdd your comment...

    3 answers

    1.  
      1
      0
      -1

      Hi Joe

      In the upcoming 4.4.1 release we are adding a new option to support this. It will require upgrading your organisation to use 4.4 Service Pack 1 however for you to be able to use it

        CommentAdd your comment...
      1.  
        1
        0
        -1

        You can upload the contents to the data field and it will work in preview but the issue you are seeing is due to a limitation in Composer. When we generate the seed XML for the form that is passed to TM as a starting point for for the pre-fill service, this data is not included in the seed. When the data is merged into the field at form start the blank element will override the value stored in the form. There are two options to work around this:

        1. If the data will not change with the pre-fill service or as part of the form and any updates will require a re-publish of the form then the simplest option is to change the binding for the data field to not bound and the form XML will not impact the value of this data field.
        2. When you publish the form to TM, go to the form version then Edit Form Data Config and in the Form XML Data tab, find the element for this data field and remove the element from the XML. The main disadvantage of this compared to option 1 is that the data in this field will end up in the submission XML which may not be desirable depending on the size of the data involved.
          CommentAdd your comment...
        1.  
          1
          0
          -1

          Hi Joe, 

          Not all files types are supported by the upload button in the Property editor.  Please ensure you've uploaded the "Other" file types from the organization resources tab to ensure they are recognized as the proper extension types.

          Cheers,

          Angie

            CommentAdd your comment...