1
0
-1

I've tried to copy a production project into a training organisation so that I can play around without breaking anything important, but I can't get anything to load in my new project.

When I try to open one of the forms, I get an error:

Problem loading form: Cannot read property 'libraryResourceData' of undefined. Click OK if you would like to continue to the form or click Cancel to close window.

The result is a blank form with no content and a bunch of error messages in the structure:

Missing Field of Type: form-header
Missing Field of Type: nav-functions
Missing Field of Type: page-controller
Missing Field of Type: navigator-wizard-bar


How do I trace back which library these assets might be stored in, or otherwise fix this?

If I try to access a template (instead of a form), I get the same error, and:

 

Missing Field of Type: form


 

    CommentAdd your comment...

    2 answers

    1.  
      2
      1
      0

      This problem is caused by a project configuration element being missing.

      To fix the issue, just follow these steps:

      1. Go to the project level of the Navigator,
      2. Then in the right-hand pane, select "Project Details"
      3. Choose a value under "Release Version" (presumably the latest version)

      The root cause of this issue will be remedied in Maestro 5.1

        CommentAdd your comment...
      1.  
        1
        0
        -1

        The configuration around which libraries are enabled / disabled for a project is not currently maintained between export/import events. There is a ticket sitting with the engineering team to rectify this (internal ref TPD-4436).

        Looks like you may be missing the maguire library and / or one of the core libraries.

        Have you checked your included libraries for the project?

        1. Sacha Trube

          I thought that if I was to export:

          1. The project
          2. Any global libraries

          .. that I would be safe - unless of course, I've missed something that's "hidden"

        2. Ben Warner

          Should be - but I suggest you spend a minute checking that the required libraries are actually listed as 'Included' on the Libraries tab of your project.

        3. Larry Bunton

          TPD-4436 will now be addressed in 5.2.

        CommentAdd your comment...