1
0
-1

I'm implementing a service that is making use of an Amazon S3 bucket.  In implementing the interface, I discovered  that "deleteobject" is a blacklisted token.  Is there some way to work around this so that I can make use of  the AmazonS3,deleteObject() call?

    CommentAdd your comment...

    3 answers

    1.  
      2
      1
      0

      Hi Thorsten,

      This issue has been resolve in TM 5.1.5 released yesterday (TPD-5451).

      Transact Manager 5.1.5 Release Notes

      regards Malcolm

      1. Thorsten Schiller

        Thank you, Malcolm.

        As an FYI to anyone else that encounters this problem on a pre-5.1.5 installation, I ended up working around this issue by going directly to the S3 REST api for the delete. 

      CommentAdd your comment...
    2.  
      2
      1
      0

      Hi,

      Are you using the Fluent API?  If your TM server was installed with the option 'Use only the secure Transact Fluent SDK', and you are using the Fluent API, deleteObject is not on the blacklist for that configuration.

      Otherwise, the blacklist is a fixed, system-wide list which includes 'deleteObject'.

      It also prohibits java.lang.reflect, so my first suggestion will not work for you.

      I've logged a change request to allow deleteObject for S3.

      1. Thorsten Schiller

        Thank you, Bill.  I have tried it with both fluent and non-fluent services so I'm assuming our server was not installed with that option.  Looks like we need to figure out a way to do this without deleting files, I guess.


        Thank you for your help!

      2. Bill Frost

        Hi Thorsten,

        The change request is in, I'll keep you informed on progress.

      CommentAdd your comment...
    3.  
      1
      0
      -1

      Thanks, Bill.  I was considering that as a fallback, but I'm not really keen on introducing a kludge to circumvent a security measure.  Ideally, I'd like to know if there is a way to remove this token from the blacklist, even if just on a per-service basis.

        CommentAdd your comment...