1
0
-1

Hello,

Having an issue where some fonts don't appear correctly in IE. We have been troubleshooting, and setup TM to no cache the browser (see image).

In Chrome when we inspect the page, the fonts are refreshed each and every time. In IE, it is still insisting on getting the fonts from the cache.

Is there a better way to force IE to not use the cache?

Thanks

    CommentAdd your comment...

    6 answers

    1.  
      1
      0
      -1

      David Barker also mentioned that on our apache server, when we "NOT" outputting 

      "Cache-Control:no-store, no-cache, must-revalidate, post-check=0, pre-check=0, private" in the response header, then IE will refresh it every time.


      If you put anything in "Cache-Control" then it will ignore the settings in there and do its own thing.

      So possibly get the infrastructure to see who sets "Cache-Control" and turn it off when the browser is IE.

        CommentAdd your comment...
      1.  
        1
        0
        -1

        I have found a way to force IE update, by go into Internet options → Browser History → Settings → Check for newer version of stored pages,  change from "automatic to "everytime I visit the page"

          CommentAdd your comment...
        1.  
          1
          0
          -1

          In cases where I'm using Maestro to work on a form and regularly publish it, and cache seems like it just won't clear, I go into TM and delete the form, then republish it from Maestro.  That has cleared all caching issues I've had in the past.

          This is because some caching occurs on the server as well.

            CommentAdd your comment...
          1.  
            1
            0
            -1

            I have attached 2 images both from IE, the first html's response header says no-cache, the second one is the font file, it stated it is getting from cache, and in the response header of the font, there isn't anything talking about no-cache.


              CommentAdd your comment...
            1.  
              1
              0
              -1

              Hi Fiona,

              Does setting the 'Always refresh from server' option in the dev tools, and then refreshing the page fix it?  Once cache refreshes, you can turn the option off again.


                CommentAdd your comment...
              1.  
                1
                0
                -1

                Hi Fiona

                Can you link the HTTP response details (probably you will need to do this from Chrome)

                  CommentAdd your comment...