1
0
-1

Hi,

In Maestro I am trying to include a Data Field in the form XML so I can include it in the Submission Data Extract Mapping in TM. I've read through the docs, tried a bunch of different settings in the Data tab etc, but still no luck. The Data Fields I have are children of a Block.Anyone have any ideas?

Cheers,
Dan

    CommentAdd your comment...

    1 answer

    1.  
      1
      0
      -1

      Hey Dan, select the field and open the Data tab on the right. Under Submission Data, select 'Include in Submission Data'.



      On the same tab under Transact Integration you can activate the data extracts capability.



      1. Dan Cormick

        Thanks Ben. Still no luck. Does it have to be Custom? I have named all IDs so I've used the 'Same as label' option.


      2. Dan Cormick

        Got it. I had the Data Config Import Option unchecked!


      3. Ben Warner

        Sorry, you also need to modify the Hidden Data policy.

        Under Hidden Data on the same tab select Clear hidden data 'Never'.

      4. Dan Cormick

        Hi Ben. I now seem to have the reverse problem. I have several items that I had mapped previously and have since removed that are still appearing in TM. I have even deleted the elements entirely from the form and yet, when I import, they still appear in the Extract Field Name list. If I edit the item and press save it gives an error saying the item does not exist in the XML.

        Extract Field Name List:



      5. Ben Warner

        Have you tried deleting the extract mapping for the fields you no longer want? I suspect the mappings are left in place so that the data for older submissions (where the extracts where relevant) still appear in the extract report.

      6. Dan Cormick

        Thanks Ben. All working now.


      CommentAdd your comment...