(Asked with Salvador Perez)

It seems that if enter data into a field with leading or trailing spaces, such as " Howard ", Maestro will automatically trim the data when it copies it to the model. So " Howard " will become "Howar


This means that if you navigate from the page to another page and back again, the field will now contain "Howard".

In most cases, this behavior is what is wanted. However, sometimes there may be a requirement to get the un-trimmed text.

Is there any simple way to change the behavior to leave the data un-trimmed?

If not, does anyone have a suggestion of how to implement this. Native component? Something else?



    CommentAdd your comment...

    1 answer


      This is the default behaviour of text inputs with AngularJS. There is an option to disable it, but we haven't exposed this as a property on the standard Maestro text field component (it's never come up before). We can add this as a property for a future release. In the meantime I can provide a patch library for your project to get early access to the new property.

        CommentAdd your comment...